Skip to main content

Posts

Showing posts from April, 2011

Jquery Quick Tabs for DotNetNuke HTML Module

If you want to quickly add tabs solution to your HTML Module than follow the below methods to accomplish it.

I have used the Microsoft Ajax CDN file reference as the following link allows me to choose different color scheme with just changing the UI css file reference.
http://www.asp.net/ajaxlibrary/CDNjQueryUI1812.ashx

In the page settings, under the page meta tag section add the following items. Make sure that the page meta tag takes the entire text and does not trims any part, if the trim or concatenation does happen, than add the remaining (entire tag) portion to the HTML module settings header section.

**********START************
<linkhref="http://ajax.aspnetcdn.com/ajax/jquery.ui/1.8.12/themes/ui-lightness/jquery-ui.css"rel="stylesheet"type="text/css"/>
<scriptsrc="http://ajax.aspnetcdn.com/ajax/jQuery/jquery-1.5.1.js"></script>
<scriptsrc="http://ajax.aspnetcdn.com/ajax/jquery.ui/1.8.12/jquery-ui.js"></script…

WebRequests to the configured external xml source are not permitted (Medium trust)

I have setup a YouTube XML channel list on my DotNetNuke website and all was working good on the staging site as it was in full trust but production being a shared hosting has a medium trust and now the IFrame and XSL rewrite script and all are useless as the web service to pull the XML from YouTube itself is failing because of the medium trust issue.

Request for the permission of type 'System.Net.WebPermission, System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089' failed.


WebRequests to the configured external xml source are not permitted (Medium trust)

Anyone has any additional update on how to fix this? without the need of compiling the entire DotNetNuke source code?

Thanks,
Wasay

I looked up these references:

http://www.dotnetnuke.com/Community/Blogs/tabid/825/EntryId/241/DotNetNuke-4-0-0-Issues-with-Medium-Trust.aspxhttp://support.microsoft.com/kb/842419

Issues: Win 7 .Net Framework 3.5 SP1 Not Installable because of previous IE9 beta install

Hi,

If you are also having issues with installing .Net Framework .35 SP1 even after enabling the features from "Turn On Windows Features" than you are in the right place.

Being a developer I installed the IE9 Beta and when windows update alerted me for updated final release browser I went for the upgrade without uninstalling the IE9 Beta.

Now I see a issues with installing plugins and softwares because they require .Net Framework 3.5 SP1 and I can't seem to install it as each time it just fails to install.

The "c:\> sfc /scannow" did found the corrupt cab files under the Internet Explorer "manifest_A197AD26-372E-4d4f-AAB9-92B5CD6B2C3A_en-us.cab" and the file is corrupted in both Program Files folder and its size differs in few kb.

I tried running command "%windir%\Microsoft.NET\Framework\v3.5\Microsoft .NET Framework 3.5\setup.exe /qb /norestart" but this alerts the folder "Microsoft .NET Framework 3.5" does not exists and in the &qu…