Skip to main content

Issues: Win 7 .Net Framework 3.5 SP1 Not Installable because of previous IE9 beta install

Hi,

If you are also having issues with installing .Net Framework .35 SP1 even after enabling the features from "Turn On Windows Features" than you are in the right place.

Being a developer I installed the IE9 Beta and when windows update alerted me for updated final release browser I went for the upgrade without uninstalling the IE9 Beta.

Now I see a issues with installing plugins and softwares because they require .Net Framework 3.5 SP1 and I can't seem to install it as each time it just fails to install.

The "c:\> sfc /scannow" did found the corrupt cab files under the Internet Explorer "manifest_A197AD26-372E-4d4f-AAB9-92B5CD6B2C3A_en-us.cab" and the file is corrupted in both Program Files folder and its size differs in few kb.

I tried running command "%windir%\Microsoft.NET\Framework\v3.5\Microsoft .NET Framework 3.5\setup.exe /qb /norestart" but this alerts the folder "Microsoft .NET Framework 3.5" does not exists and in the "v3.5" folder there is no "setup.exe" either so not sure from where I am suppose to run this command.

Looking at the log "c:\> findstr /c:"[SR]" %windir%\Logs\CBS\CBS.log > sfcdetails.txt" yeilded nothing much either.

I am feeling I am running out of options but one last try is to uninstall IE9 and go back on IE8 and then see if that solves anything.

I will update this blog after some information from these steps and others. Let me know if you have any suggestions or solutions.

Thanks.