Skip to main content

WebRequests to the configured external xml source are not permitted (Medium trust)

I have setup a YouTube XML channel list on my DotNetNuke website and all was working good on the staging site as it was in full trust but production being a shared hosting has a medium trust and now the IFrame and XSL rewrite script and all are useless as the web service to pull the XML from YouTube itself is failing because of the medium trust issue.

Request for the permission of type 'System.Net.WebPermission, System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089' failed.


WebRequests to the configured external xml source are not permitted (Medium trust)

Anyone has any additional update on how to fix this? without the need of compiling the entire DotNetNuke source code?

Thanks,
Wasay

I looked up these references:


Comments

Popular posts from this blog

Completed UiPath - RPA Developer Advance Training

After a month of training, with late nights and weekends I have completed the UiPath RPA Developer Advance Training.

The Level 1 Foundation Training pretty much covered all the basics of Desktop studio and workflows, only draw back was I started with the default foundation course which was for 2016, and all document reference links where pointing to 2016 version. I didn't understand it during the foundation training and kept switching to 2018 version document/page.

Only after completing the Foundation course that I realized, I was suppose to have started with the 2018 version of Level 1 Foundation Training, but as it was optional I didn't have to retake the 2018 version, the 2016 was good enough for moving to level 2.

The Level 2 Orchestrator 2018.3 Training as good. It gave good understanding of Queue's, Jobs, and schedules and I was able to complete the level two much faster then the level 1.

The Level 3 UiPath Advanced Training was bit tough as it involved the assignme…

KB 294807 - IIS Server - PHP FastCGI 500 Error 0xfffffffe

Resolved issue today of IIS Server - PHP FastCGI 500 Error 0xfffffffe by deleting "Windows Temp" folder files.

We used Cygwin to customize some permissions of "Windows Temp" folder and after few hours the website stopped working.

The search online was giving all kinds of different solution except what I was looking for.

I was hoping the stackoverflow will have answers but even this post didn't cover the issue I was running into.
https://stackoverflow.com/questions/15302080/fastcgi-500-failure

Restarting the IIS didn't work, but deleting temp files cleared the issue, but now the problem is how long before the site will go down again?

Hope the issue is resolved for ever, if not; I will update this post later.

Grow with Google Scholarship / Udacity

Grow with Google Scholarship / Udacity

Today on Jan 11, 2018, I have received the Grow with Google Scholarship.

I am really excited because, previously I had joined Udacity to complete a Nano Degree, but due to price and family priorities, I had to abandon that goal.

Today, I feel like I am getting a second chance to give it another shot to completing my Nano Degree.